Skip to content

Gettin Erors NodeBB

Solved Configure
7 2 2.0k 1
  • Hi,
    Started to get eror message as below;

    Error: revalidate-failure
        at validateSession (/home/nodes/nodebb/src/socket.io/index.js:216:9)
        at runMicrotasks (<anonymous>)
        at processTicksAndRejections (internal/process/task_queues.js:95:5)
        at async onMessage (/home/nodes/nodebb/src/socket.io/index.js:153:3)
    
  • @cagatay interesting. Aside from the error messages, does this impact the forum operation itself?

    @phenomlab no forum is working goods.
    there is no eror message since yestarday.

  • Hi,
    Started to get eror message as below;

    Error: revalidate-failure
        at validateSession (/home/nodes/nodebb/src/socket.io/index.js:216:9)
        at runMicrotasks (<anonymous>)
        at processTicksAndRejections (internal/process/task_queues.js:95:5)
        at async onMessage (/home/nodes/nodebb/src/socket.io/index.js:153:3)
    

    @cagatay That appears to be an issue with the socket service on your server. Does this happen frequently, and if so, how often ? For the most part, this is typically intermittent, but if it is occuring frequently, it does need to be checked.

  • @cagatay That appears to be an issue with the socket service on your server. Does this happen frequently, and if so, how often ? For the most part, this is typically intermittent, but if it is occuring frequently, it does need to be checked.

    @phenomlab not often but now i see another eror;

    Error: Login sessions require session support. Did you forget to use `express-session` middleware?
        at SessionStrategy.authenticate (/home/nodes/nodebb/node_modules/passport/lib/strategies/session.js:46:41)
        at attempt (/home/nodes/nodebb/node_modules/passport/lib/middleware/authenticate.js:369:16)
        at authenticate (/home/nodes/nodebb/node_modules/passport/lib/middleware/authenticate.js:370:7)
        at Layer.handle [as handle_request] (/home/nodes/nodebb/node_modules/express/lib/router/layer.js:95:5)
        at trim_prefix (/home/nodes/nodebb/node_modules/express/lib/router/index.js:328:13)
        at /home/nodes/nodebb/node_modules/express/lib/router/index.js:286:9
        at Function.process_params (/home/nodes/nodebb/node_modules/express/lib/router/index.js:346:12)
        at next (/home/nodes/nodebb/node_modules/express/lib/router/index.js:280:10)
        at initialize (/home/nodes/nodebb/node_modules/passport/lib/middleware/initialize.js:98:5)
        at Layer.handle [as handle_request] (/home/nodes/nodebb/node_modules/express/lib/router/layer.js:95:5)
    2022-11-08T17:00:00.020Z [4567/223452] - info: [user/jobs] Did not send digests (day) because subscription system is disabled.
    
  • @phenomlab not often but now i see another eror;

    Error: Login sessions require session support. Did you forget to use `express-session` middleware?
        at SessionStrategy.authenticate (/home/nodes/nodebb/node_modules/passport/lib/strategies/session.js:46:41)
        at attempt (/home/nodes/nodebb/node_modules/passport/lib/middleware/authenticate.js:369:16)
        at authenticate (/home/nodes/nodebb/node_modules/passport/lib/middleware/authenticate.js:370:7)
        at Layer.handle [as handle_request] (/home/nodes/nodebb/node_modules/express/lib/router/layer.js:95:5)
        at trim_prefix (/home/nodes/nodebb/node_modules/express/lib/router/index.js:328:13)
        at /home/nodes/nodebb/node_modules/express/lib/router/index.js:286:9
        at Function.process_params (/home/nodes/nodebb/node_modules/express/lib/router/index.js:346:12)
        at next (/home/nodes/nodebb/node_modules/express/lib/router/index.js:280:10)
        at initialize (/home/nodes/nodebb/node_modules/passport/lib/middleware/initialize.js:98:5)
        at Layer.handle [as handle_request] (/home/nodes/nodebb/node_modules/express/lib/router/layer.js:95:5)
    2022-11-08T17:00:00.020Z [4567/223452] - info: [user/jobs] Did not send digests (day) because subscription system is disabled.
    

    @cagatay which site was this taken from ?

  • @cagatay which site was this taken from ?

    @phenomlab efelsefe.

    uzayyolu is working without problem.

  • @phenomlab efelsefe.

    uzayyolu is working without problem.

    @cagatay interesting. Aside from the error messages, does this impact the forum operation itself?

  • @cagatay interesting. Aside from the error messages, does this impact the forum operation itself?

    @phenomlab no forum is working goods.
    there is no eror message since yestarday.

  • phenomlabundefined phenomlab has marked this topic as solved on

Did this solution help you?
Did you find the suggested solution useful? Support 💗 Sudonix with a coffee ☕
If your organisation needs deeper expertise around infrastructure, security, or technology leadership, learn more about Phenomlab Ltd. Many of the deeper technical guides behind Sudonix are published there.

Related Topics
  • Nodebb and emails

    Solved Configure nodebb
    27
    5 Votes
    27 Posts
    9k Views
    @Panda it will use SMTP. In all cases, I never use any plugin to send email. I’ll always send it raw.
  • Fixed background to nodebb forum

    Solved Configure nodebb
    25
    4 Votes
    25 Posts
    9k Views
    @Panda said in Fixed background to nodebb forum: Chatgpt told me the ::before method. Go figure
  • Where are widgets stored?

    Solved Configure nodebb
    3
    1 Votes
    3 Posts
    1k Views
    @phenomlab Thanks, have DMed you
  • NodeBB v3 Quick reply

    Solved Configure quick reply button
    4
    1
    2 Votes
    4 Posts
    1k Views
    here is the link: https://app.transifex.com/nodebb/nodebb/translate/#tr
  • Want to use Sudonix themes ?

    Chitchat themes nodebb
    80
    1
    34 Votes
    80 Posts
    27k Views
    omg thank you Mark.
  • NodeBB: Upgrading to NodeBB v3.x

    Solved Configure nodebb v3.x
    6
    0 Votes
    6 Posts
    2k Views
    @mventures You’d need to connect to the server and execute it directly - not on your local terminal. Review the guide below, which will show you how to gain access via SSH to your server https://docs.ovh.com/gb/en/dedicated/ssh-introduction/ Once you have access, you’ll need to navigate to the actual folder where NodeBB is installed You’ll then need to change to the directory as shown below /home/unbuntu/nodebb [image: 1680448167972-fdffe673-bf63-4b6d-a728-5506fddc1aff-image.png] In most cases, initial access takes you to the root of the file system. You can always issue pwd in a Linux terminal which will show you the Present Working Directory. From there, you can issue the command cd /home/ubuntu/nodebb Once in the NodeBB directory, you’d use the below commands ./nodebb stop git fetch && git checkout develop && git reset --hard origin/develop ./nodebb upgrade ./nodebb start Line 1 stops the NodeBB instance Line 2 gets the latest files from GIT (repository) and then checks out the development branch. It then resets the version you are using to the development branch ready for v3 Line 3 Runs the upgrade once the new branch is set, and code pulled Line 4 Restarts the NodeBB instance after the upgrade has completed Note that when you restart NodeBB and log back in, things will look very different to what you had in v2.
  • restarting nodebb on boot

    Unsolved Configure nodebb
    3
    1 Votes
    3 Posts
    2k Views
    @eeeee said in restarting nodebb on boot: can I just run nodebb under nodemon for auto restarts? It’s a better method. Nodemon just looks for file system changes and would effectively die if the server was rebooted meaning you’d have to start it again anyway. Systemd is the defacto standard which is how the operating system interacts in terms of services, scheduled tasks etc.
  • Configure SMTP for Nodebb

    Solved Configure
    14
    5 Votes
    14 Posts
    4k Views
    @marusaky based on the work completed thus far (in relation to PM exchanges), I’m going to mark this completed. Sending email from the server itself works fine without issue, and DNS appears to be clean (valid SPF, DMARC, and DKIM records). It appears that only Gmail marks incoming messages from your domain as spam - perhaps because of the domain age, which there is nothing we can do to prevent this. Mail delivery to all other domains appears to work fine in al of my tests.